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• Now it is a right time for some activities again 

• Our goal is to adjust the configuration of SW4STM32 environment.

• You can follow next steps directly on your “L4_Blinky” project.
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Our goals for this session

Get knowledge about some features of SW4STM32 toolchain:

Selection C dialect and parallel build options

Configuration of the indexer

How to run an external application

How to set autosave before build option

How to use “come back later” messages within the code

How to use and configure autocompleting option

Managing different output files (.hex, .bin files generation)

How to run debug session and handling most common issues related to this operation
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Some tips in SW4STM32



Code generation strategies for SW4STM32
generation of project files under root or in dedicated folder

• There are two ways how to generate project files for SW4STM32 from STM32CubeMX application:

1. Generate the toolchain project files in STM32CubeMX user project root folder (Generate under root 

checkbox should be selected) -> we will use this option during this session

2. Generate the toolchain project files in dedicated toolchain folder  (Generate under root checkbox should 

be not selected)

• STM32CubeMX project generation under the root folder allows to:

• Optional copy of the project into the Eclipse workspace when importing a project.

• Use of source control systems such as GIT or SVN from the Eclipse workspace.

• Warning: Choosing to copy the project into workspace will prevent any further synchronization 

between changes done in Eclipse and changes done in STM32CubeMX as there will be 2 different 

copies of the project.
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Useful project settings in SW4STM32 
configuring C dialect and parallel build

1. Configure C standard 

to C99 to avoid 

possible compilation 

errors

2. Check Enable parallel 

build to make use of 

your machine potential 

and to shorten 

compilation time

C/C++ Build->Settings->Tools Settings tab   MCU GCC Compiler->Dialect

C/C++ Build->Behavior tab 

1

2

NOTE: These steps were already mentioned in a previous part, here duplicated to keep narration consistency.

Project->Properties



Indexer in SW4STM32 7

• The indexer uses the parser to create a database of project files that provides the 

basis for search, navigation features and parts of content assist (Ctrl+Space

feature).

• The indexer runs on a background and reacts to resource change like: 

 Project creation/deletion

 Source files creation/deletion

 File imports

 Source file content changes

• It is possible to customize the behavior of the indexer (or turn it off) for each project 

within the workspace separately.



Compiler optimization levels 8

• Optimization levels are accessible within project properties (right click the project name)

• Within project Properties select:

C/C++ Build -> Settings ->Tool Settings->MCU GCC Compiler->Optimization From

• From drop-down menu select required optimization level

• Click Apply->OK buttons when completed



Issue with missing _IRQn

• During code generation with “Generate 

Under Root” option selected, all 

header files for a complete family are 

added to the project causing an error 

with unresolved parameter (too many 

sources with the same definition) 

this is necessary to change indexer 

settings. 
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uncheck this option

check this option

Project Properties->C/C++ General->Indexer



Run an external application

Example: How to erase Flash memory using command line STLink Utility application from SW4STM32
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1. Select External Tools Configuration from Run 

configuration option

2. Double click Program to create new configuration

3. Browse ST-LINK_CLI.exe within File System

4. Add –c SWD UR –ME arguments 

• -c SWD  use SWD to connect to the target

• UR  connect under reset

• -ME  mass erase of the FLASH memory

5. Run the program 

(ST-LINK_CLI.exe –c SWD UR –ME will be executed)

1

2

3

4
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Useful configuration
auto save on build and launch

11

Editor settings are available in WindowsPreferences menu

General->Workspace

Run/Debug->Launching



Adding files to the project
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1. Right-click the files folder within the project to select IMPORT 

2. Select General->File System

3. Browse for files to be imported (sine.h in below example)

4. Select import options (click on Advanced button) and click Finish button

5. File will pop-up in selected folder

2

1

3

4

File will be imported 

as link if selected (by 

default not selected)

File copied into the folder

File linked to the folder
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Importing projects into workspace
import from archive file

2

3

4
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1. Select File->Import from SW4STM32 main menu

2. Select “Existing Projects…” from Import->General window

Projects will be added 

into current workspace.
Select project from the 

Projects lists and press Finish

Select “Select archive file” 

and browse proper .zip /.tar 

file from Import Project 

window



Project refresh after configuration change

• After performing any change to 

optimization/debug level, we strongly 

recommend to refresh project 

configuration (F5) and to build it again
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Enable float support in printf

• By default “nano” version of 

the stdio (standard input-

output library) is selected. 

• This helps to keep code size 

low but does not allow use of 

float numbers in printf. 

• In order to change it, we have 

to disable “nano” library option 

within project settings.
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Remove this option

C/C++ Build -> Settings -> MCU GCC Linker -> Miscellaneous



“Come Back Later” – Tasks

• Task configuration is done in Task Tags field within WindowPreferencesC/C++

• This is possible to add new and modify existing keywords that will be recognized after saving 

source file as Tasks marking (even being inside comment field - example (1) below).

• Double-clicking the particular task moves to the place of the code where the task is placed (2)
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Auto completion of the generic C code

• Basic configuration is done within:

• WindowPreferencesC/C++EditorContent Assist

• Templates configuration is done within 

• WindowPreferencesC/C++EditorTemplates

• Insert by Ctrl+Space during typing, i.e. 

for <Ctrl+Space>

then select required template to be used
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for (int var = 0; var < max; ++var) {

}



Managing output files
useful modifications in post-build steps
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• Open properties window for the project (ProjectProperties)

• Select C/C++BuildSettingsBuild Steps

• Modify Command field using below information 

(this is possible to add new commands after a && string)

• To generate a binary (.bin) output file use:

arm-none-eabi-objcopy –O binary “out_file.elf” “out_file.bin”

• To generate an INTEL hex (.hex) output file use:

arm-none-eabi-objcopy –O ihex “out_file.elf” “out_file.hex”

• To print information about code size after compilation use:

arm-none-eabi-size “out_file”



Restoring default configuration
resetting the perspective 19

• Perspective is a configuration of the windows and toolbars within current SW4STM32 workspace.

• There are different perspectives for editing, debugging, file sharing etc.

• Perspectives can by modified by the user (WindowPerspective)

• There is a function available to reset the perspective to its default view.

• This option is available in WindowPerspectiveReset Perspective

Example:

Before (no project explorer nor 

output console windows)

After (project explorer and output 

console windows are restored)Select WindowPerspectiveReset Perspective



Issues with entering debug session
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There are few typical root causes of the issues when entering debug mode:

• Wrong version of the HW debugger selected: i.e. STLinkV2-1 instead of STLinkV2 or vice versa

• Already running debug session(s)

• STLink owned by other debug/programming application (i.e. STMStudio, STLink Utility)

• A “ghost” GDB process existing in PC memory and locking an access to the debug port

• Wrong connection type selected. Debugged MCU requires connect under reset option – it can be 

corrected within .cfg configuration file or by erasing the memory by STLink Utility application

Some PC oriented issues can be verified by connection trial using STLink Utility. Those are typically: 

• Bad quality USB cable (especially when we use board with high current consumption)

• An issue with USB port (some USB3.0 ports show problems with correct operation with STLink)

In most of the cases root cause can be tracked by turn-on more verbose debug session 

(please refer to the next slide)



Issues with entering debug session
more verbose debug session 22

• An useful option is increasing debug 

level to 3 in OpenOCD configuration

• It generates much more messages 

concerning OpenOCD operations 

helping us to detect a root cause of 

the issue with debug session

• To do it, please add –d3 option in 

OpenOCD Command within current 

debug configuration
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Issues with entering debug session
detecting still running debug sessions

To detect still running debug sessions, 

please switch to debug perspective

1. If the                   button is not 

available, please click       button 

(or go to Window->Perspective-

>Open Perspective) and select 

“Debug” line form the list

2. Please have a look whether there 

are running debug sessions in the 

Debug window

3. To close them, they should be first 

terminated (STOP button) and then 

removed (XX button)

4. After removing all missed debug 

sessions, try to run debug session 

once again.

1

2

3

4
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Issues with entering debug session
detecting “ghost” GDB processes in the system

• Display list of active tasks in the PC (Windows OS) by pressing 

Ctr+Alt+Del and select “Start Task Manager”

• Select “Processes” tab from Windows Task Manager

• Highlight “ghost” arm-none-eabi-gdb.exe process

• Press End Process button



Issues with entering into debug session
detecting issue with busy STLink
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• Configure more verbose debug session (-d3 option)

• Run debug session and observe the messages displayed under Console tab 

• Identify lines with Error attribute (first column in an example below)



Managing multiproject workspace
closing and opening projects
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• In the workspaces which contains more projects there is a risk of work on the sources from inactive 

project

• For this reason a good practice is to close inactive projects (it is not related to any project/file 

erasing). 

• To close the project, please click right mouse button on project name and select “Close Project”

• To close all opened, but not active project, please click right mouse button on the active project 

name and select “Close Unrelated Projects”

• To reopen closed project, please double click left mouse button on its name or click right mouse 

button on project name and select “Open Project”

Opened active project

Opened inactive project

Closed projects



Managing debug session
multiproject workspace
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• In the workspaces which contains more 

projects there is a risk that we are 

running not correct debug session (by 

simple click on “bug” icon)

• To display available debug sessions 

within the workspace please use Run-

>Debug Configurations on click on 

small “down” arrow near the “bug” button

• To select a correct  debug session, 

please click on its name

• To delete any debug configuration press 

red ‘X” button



Our goals for this session

Get knowledge about some features of SW4STM32 toolchain:

Selection C dialect and parallel build options

Configuration of the indexer

How to run an external application

How to set autosave before build option

How to use “come back later” messages within the code

How to use and configure autocompleting option

Managing different output files (.hex, .bin files generation)

How to run debug session and handling most common issues related to this operation
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Enjoy!

www.st.com/mcu

/STM32 @ST_World st.com/e2e

http://www.st.com/stm32l4

